Realtime Memory High Performance

AldenAlden Member

Hi everyone,

I have a TH3030S device always in high performance of Realtime Memory status (85% - 88%)

Although I have not set anything, only set ip management.

How can I fix it and what is the root cause?

Best regards!


Comments

  • jacksondoejacksondoe Member

    Improve performance in Realtime System

    1. Minimize Tasks in the Application.
    2. Use Memory Block Pools over Byte Pools.
    3. Don't Create and Destroy Objects.
    4. Consider Using Event Flags.
    5. Minimize RTOS Objects.
    6. Optimize the Task Stacks.
    7. Turn Off Unused Features.


  • AldenAlden Member

    Hi jacksondoe,

    Sorry about my information is not correct. My device model is AX3000 not TH3030S.

    And the TAC supporter advices me use the version 2.7.2-P16 for this model.

    After set the version 2.7.2 for device, the memory usage about 67%. He also said that is normal, the memory is pre-allocated.

    But I still think it is high performance :(

    How about your ideas?

    Best regards!


  • mdunnmdunn Member ✭✭

    Hi Alden,

    The feedback from TAC regarding the pre-allocation of memory is accurate. It is normal to see utilization of this level. As the device uptime and utilization increases, you should see only a minimal increase in memory unless the system is reaching its specification limits.

Sign In or Register to comment.