A10 AXv Thunder 4.0.1 Disk Space issue

Hi there,

Currently have an instance of A10 AXv Thunder 4.0.1.

Issue I have is that I am unable to increase the disk space within the the software.

I have increase the disk in VMWare and the console shows the new 'total' disk space but free space stays the same, appliances keeps showing error 'Ramdisk is mounted READ ONLY' which causes issues with new connection.
I've tried to free up space by remove log files.

Also this is stopping my from going a backup to run up another instance of a10.

Any help would be greatly appreciated.



  • yaojencyaojenc Member
    edited November 2018
    Hi Kyle,

    Since I couldn't find vThunder 4.0.1 (yet), I had tried this out with vThunder 4.1.4 on my lab ESXi5.5. Though I couldn't replicate the issue you reported.

    When simply resized the Disk from VMware ESXi while vThunder is active, vThunder didn't detect any disk size change nor any error. This new 'total' disk space showed up only after a reboot (PowerOn at VMware).

    With that being said, you may want to open a TAC ticket to get support from our TAC group.

  • diederikdiederik Member
    edited November 2018

    For A10 SoftAX/vThunder resizing of HDD space is not supported.
    Reserving enough HDD space ruding first install is required.

    With VCS keeping copies of the various upgrade packages to be available for syncing to other clsuter members, especially with the default HDD size settings, you can run out of space pretty quickly.

    You can have TAC "clean" your system to see if this frees enough space for a backup.
    With 4.x it is adviced to make at least 20GB HDD space available to the vThunder.

    Personally I'd say add at leat 5 to 10GB to that.

    If your current setup does not have enough HDD space, TAC can assist with re-licensing a new install.


  • edited December 2018
    Thanks for the replies, I was able to backup the system files through CLI and restore to a new instance, it appears that v4.01 is set to 12Gb HDD and when expanded even before powered on for the first time it won't recognize as 'free space' just shows as used space.

    New issue I have found is that the interfaces in the virtual appliance are set to 10Mb auto, anyone else come across this? Apparently is it a bug. https://dev-a10wp.pantheonsite.io/forums/topic/interface-speed-and-duplex-after-upgrade/

    So i than ran up another instance of A10 AXv Thunder v4.1 and restored from backup. All looks to be OK but connections from my outside interface are getting a 'err_connection_reset'

    Any ideas of what would be different from v4.01 to v4.1 within the configuration? The show run and installed SSL certificates are identical.

  • diederikdiederik Member
    edited December 2018

    If your system is licensed properly, and you are using VMXNET3 for the data interfaces, there should be no issue.

    As far as I know, the bug you reference has also been fixed in the current 4.0.1 codes and was related to systems with SFP's, not vThunder.

    I'm not sure if there could be an issue if you have restored a 4.0.1 backup into a 4.1.4 system. The config structure should be the same, I am not sure of the file structure is the same though.
    I would strongly advise against restoring backups into different code versions... difference in P release should be ok.


Sign In or Register to comment.