LACP trunk failing in transparent mode
in System
Hi all,
I'm new to a10 stuff, and I'm trying to set up some new AX3200-12.
I'm trying to set up the devices in transparent mode with a pair of data interfaces bonded to a cisco switch using LACP negotiation.
I can set up the trunk interfaces fine, and the switch shows that the port-channel is build properly, but as soon as I add the transparent IP address to the config, the port-channel on the Cisco switch drops to two Independent interfaces instead of a channel, and the AX goes blocking on the ethernet interfaces
Am I doing something wrong, or is this how it should work in transparent mode?
This is the interfaces connected initially, very basic.
-------------------------------------------------
sw#
Group Port-channel Protocol Ports
------+-------------+-----------+-----------------------------------------------
45 Po45(SU) LACP Gi3/0/9(P) Gi4/0/9(P)
lb01(config)#show run | exclude ^!
hostname lb01
clock timezone Europe/Dublin
interface management
ip address 172.30.61.41 255.255.255.0
ip default-gateway 172.30.61.254
ip control-apps-use-mgmt-port
interface ethernet 1
name "e1-shared"
lacp trunk 1 mode active
lacp timeout long
interface ethernet 2
name "e2-shared"
lacp trunk 1 mode active
lacp timeout long
interface ethernet 3
disable
{snip}
interface ethernet 28
disable
end
lb01(config)#
lb01(config)#show trunk
Trunk ID : 1 Member Count: 2
Trunk Status : Up
Trunk Type : Dynamic (LACP)
Admin Key : 1001
Members : 1 2
Cfg Status : Enb Enb
Oper Status : Up Up
Ports-Threshold : None
Working Lead : 2
lb01(config)#
-------------------------------------------------
Then when I add the transparent interface address it worked initially, then it was blocked, or if it was working, then I reload the AX, it blocks..
If I disable one of the ethernet interfaces, and reload it- it links up alright..
-------------------------------------------------
lb01#show run | exc ^!
hostname lb01
clock timezone Europe/Dublin
ip address 172.30.48.251 255.255.255.0
ip default-gateway 172.30.48.254
interface management
ip address 172.30.61.41 255.255.255.0
ip default-gateway 172.30.61.254
ip control-apps-use-mgmt-port
interface ethernet 1
name "e1-shared"
lacp trunk 1 mode active
lacp timeout long
interface ethernet 2
name "e2-shared"
lacp trunk 1 mode active
lacp timeout long
interface ethernet 3
disable
{snup}
interface ethernet 28
disable
end
lb01#
lb01# show trunk
Trunk ID : 1 Member Count: 2
Trunk Status : Down
Trunk Type : Dynamic (LACP)
Admin Key : 1001
Members : 1 2
Cfg Status : Enb Enb
Oper Status : Blk Blk
Ports-Threshold : None
Working Lead : None
lb01#
-------------------------------------------------
Am I doing something wrong? - at the moment my head is spinning :S
I'm new to a10 stuff, and I'm trying to set up some new AX3200-12.
I'm trying to set up the devices in transparent mode with a pair of data interfaces bonded to a cisco switch using LACP negotiation.
I can set up the trunk interfaces fine, and the switch shows that the port-channel is build properly, but as soon as I add the transparent IP address to the config, the port-channel on the Cisco switch drops to two Independent interfaces instead of a channel, and the AX goes blocking on the ethernet interfaces
Am I doing something wrong, or is this how it should work in transparent mode?
This is the interfaces connected initially, very basic.
-------------------------------------------------
sw#
Group Port-channel Protocol Ports
------+-------------+-----------+-----------------------------------------------
45 Po45(SU) LACP Gi3/0/9(P) Gi4/0/9(P)
lb01(config)#show run | exclude ^!
hostname lb01
clock timezone Europe/Dublin
interface management
ip address 172.30.61.41 255.255.255.0
ip default-gateway 172.30.61.254
ip control-apps-use-mgmt-port
interface ethernet 1
name "e1-shared"
lacp trunk 1 mode active
lacp timeout long
interface ethernet 2
name "e2-shared"
lacp trunk 1 mode active
lacp timeout long
interface ethernet 3
disable
{snip}
interface ethernet 28
disable
end
lb01(config)#
lb01(config)#show trunk
Trunk ID : 1 Member Count: 2
Trunk Status : Up
Trunk Type : Dynamic (LACP)
Admin Key : 1001
Members : 1 2
Cfg Status : Enb Enb
Oper Status : Up Up
Ports-Threshold : None
Working Lead : 2
lb01(config)#
-------------------------------------------------
Then when I add the transparent interface address it worked initially, then it was blocked, or if it was working, then I reload the AX, it blocks..
If I disable one of the ethernet interfaces, and reload it- it links up alright..
-------------------------------------------------
lb01#show run | exc ^!
hostname lb01
clock timezone Europe/Dublin
ip address 172.30.48.251 255.255.255.0
ip default-gateway 172.30.48.254
interface management
ip address 172.30.61.41 255.255.255.0
ip default-gateway 172.30.61.254
ip control-apps-use-mgmt-port
interface ethernet 1
name "e1-shared"
lacp trunk 1 mode active
lacp timeout long
interface ethernet 2
name "e2-shared"
lacp trunk 1 mode active
lacp timeout long
interface ethernet 3
disable
{snup}
interface ethernet 28
disable
end
lb01#
lb01# show trunk
Trunk ID : 1 Member Count: 2
Trunk Status : Down
Trunk Type : Dynamic (LACP)
Admin Key : 1001
Members : 1 2
Cfg Status : Enb Enb
Oper Status : Blk Blk
Ports-Threshold : None
Working Lead : None
lb01#
-------------------------------------------------
Am I doing something wrong? - at the moment my head is spinning :S
Tagged:
0
Comments
We were investigating the issue you described if you are still having trouble we can arrange a
a remote session to take a look at your configuration.
I would liek to get this working with the LACP trunk, but I currently have set it up using a static trunk, and it seems to be heppy with that.
I should be able to blast the config on one of these devices and try this again easy enough so you can take a look at this.
Could you let us know what you mean by the Cisco switch drops to 2 independent interfaces instead of a port channel? Also would it be possible to get the switch configuration for those 2 ports?
Please let us know. Thank you.
############################################################################
~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
lb01#show run
!Current configuration: 1468 bytes
!Configuration last updated at 17:14:48 IST Fri Aug 31 2012
!Configuration last saved at 17:05:00 IST Fri Aug 31 2012
!version 2.6.1-GR1-P3, build 29 (Jul-14-2012,15:46)
!
hostname lb01
!
clock timezone Europe/Dublin
!
interface management
ip address 172.30.61.42 255.255.255.0
ip default-gateway 172.30.61.254
ip control-apps-use-mgmt-port
!
interface ethernet 1
name "e1-shared"
lacp trunk 1 mode active
lacp timeout long
!
interface ethernet 2
name "e2-shared"
lacp trunk 1 mode active
lacp timeout long
!
end
lb01#
~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
swCORE#show etherchannel 46 summary
Flags: D - down P - bundled in port-channel
Group Port-channel Protocol Ports
------+-------------+-----------+-----------------------------------------------
46 Po46(SU) LACP Gi3/0/10(P) Gi4/0/10(P)
!
interface Port-channel46
description [lb02]
switchport access vlan 99
switchport trunk encapsulation dot1q
switchport mode trunk
spanning-tree bpduguard enable
!
interface GigabitEthernet3/0/10
description lb02-T1L1
switchport access vlan 99
switchport trunk encapsulation dot1q
switchport mode trunk
spanning-tree portfast
spanning-tree bpduguard enable
channel-group 46 mode active
!
interface GigabitEthernet4/0/10
description lb02-T1L2
switchport access vlan 99
switchport trunk encapsulation dot1q
switchport mode trunk
spanning-tree portfast
spanning-tree bpduguard enable
channel-group 46 mode active
end
~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
lb01#show lacp trunk detail
Aggregator po1 1000000
Mac address: 00:1f:a0:05:6b:72
Admin Key: 0001 - Oper Key 0001
Receive link count: 1 - Transmit link count: 0
Individual: 0 - Ready: 1
Partner LAG- 0x8000,00-25-45-40-cf-00
Link: ethernet 2 (5) sync: 1
Link: ethernet 1 (4) sync: 1
lb01#
~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
swCORE#show etherchannel 46 detail
Group state = L2
Ports: 2 Maxports = 16
Port-channels: 1 Max Port-channels = 16
Protocol: LACP
Minimum Links: 0
Ports in the group:
-------------------
Port: Gi3/0/10
------------
Port state = Up Mstr Assoc In-Bndl
Channel group = 46 Mode = Active Gcchange = -
Port-channel = Po46 GC = - Pseudo port-channel = Po46
Port index = 0 Load = 0x00 Protocol = LACP
Flags: S - Device is sending Slow LACPDUs F - Device is sending fast LACPDUs.
A - Device is in active mode. P - Device is in passive mode.
Local information:
LACP port Admin Oper Port Port
Port Flags State Priority Key Key Number State
Gi3/0/10 SA bndl 32768 0x2E 0x2E 0x30B 0x3D
Partner's information:
LACP port Admin Oper Port Port
Port Flags Priority Dev ID Age key Key Number State
Gi3/0/10 SA 32768 001f.a005.6b70 13s 0x0 0x1 0x4 0x3D
Age of the port in the current state: 0d:00h:04m:38s
Port: Gi4/0/10
------------
Port state = Up Mstr Assoc In-Bndl
Channel group = 46 Mode = Active Gcchange = -
Port-channel = Po46 GC = - Pseudo port-channel = Po46
Port index = 0 Load = 0x00 Protocol = LACP
Flags: S - Device is sending Slow LACPDUs F - Device is sending fast LACPDUs.
A - Device is in active mode. P - Device is in passive mode.
Local information:
LACP port Admin Oper Port Port
Port Flags State Priority Key Key Number State
Gi4/0/10 SA bndl 32768 0x2E 0x2E 0x40B 0x3D
Partner's information:
LACP port Admin Oper Port Port
Port Flags Priority Dev ID Age key Key Number State
Gi4/0/10 SA 32768 001f.a005.6b70 12s 0x0 0x1 0x5 0x3D
Age of the port in the current state: 0d:00h:04m:38s
Port-channels in the group:
---------------------------
Port-channel: Po46 (Primary Aggregator)
------------
Age of the Port-channel = 0d:00h:49m:43s
Logical slot/port = 10/46 Number of ports = 2
HotStandBy port = null
Port state = Port-channel Ag-Inuse
Protocol = LACP
Port security = Disabled
Ports in the Port-channel:
Index Load Port EC state No of bits
------+------+------+------------------+-----------
0 00 Gi3/0/10 Active 0
0 00 Gi4/0/10 Active 0
Time since last port bundled: 0d:00h:04m:38s Gi4/0/10
Time since last port Un-bundled: 0d:00h:56m:59s Gi3/0/10
GBSHEswCORE#
~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
############################################################################
~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
## Now put in the IP address for transparent mode
lb01(config)#ip address 172.30.48.251 255.255.255.0
lb01(config)#ip default-gateway 172.30.48.254
lb01(config)#show trunk
Trunk ID : 1 Member Count: 2
Trunk Status : Up
Trunk Type : Dynamic (LACP)
Admin Key : 1001
Members : 1 2
Cfg Status : Enb Enb
Oper Status : Up Up
Ports-Threshold : None
Working Lead : 2
lb01(config)#
~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
############################################################################
~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
## this initially seems to be working and the trunk is still active
Previously I left this for a while as I was doing some other work, and when I checked it had failed into blocking state.
I have just managed to force this to fail, by reloading the AX and when it come back up - the trunk interface will not establish, and the switch is showing the trunk interfaces as being in Independent mode, wheras the AX is showing both interfaces of the trunk as Down and Blocking
lb01#show trunk
Trunk ID : 1 Member Count: 2
Trunk Status : Down
Trunk Type : Dynamic (LACP)
Admin Key : 1001
Members : 1 2
Cfg Status : Enb Enb
Oper Status : Blk Blk
Ports-Threshold : None
Working Lead : None
lb01#
swCORE(config-if)#do show etherchannel 46 summary
Flags: D - down P - bundled in port-channel
I - stand-alone s - suspended
w - waiting to be aggregated
Group Port-channel Protocol Ports
------+-------------+-----------+-----------------------------------------------
46 Po46(SD) LACP Gi3/0/10(w) Gi4/0/10(w)
swCORE(config-if)#do show etherchannel 46 summary
Flags: D - down P - bundled in port-channel
I - stand-alone s - suspended
w - waiting to be aggregated
Group Port-channel Protocol Ports
------+-------------+-----------+-----------------------------------------------
46 Po46(SD) LACP Gi3/0/10(I) Gi4/0/10(I)
swCORE(config-if)#do show etherchannel 46 detail
Group state = L2
Ports: 2 Maxports = 16
Port-channels: 1 Max Port-channels = 16
Protocol: LACP
Minimum Links: 0
Ports in the group:
-------------------
Port: Gi3/0/10
------------
Port state = Up Sngl-port-Bndl Mstr Not-in-Bndl
Channel group = 46 Mode = Active Gcchange = -
Port-channel = null GC = - Pseudo port-channel = Po46
Port index = 0 Load = 0x00 Protocol = LACP
Flags: S - Device is sending Slow LACPDUs F - Device is sending fast LACPDUs.
A - Device is in active mode. P - Device is in passive mode.
Local information:
LACP port Admin Oper Port Port
Port Flags State Priority Key Key Number State
Gi3/0/10 SA indep 32768 0x2E 0x2E 0x30B 0x7D
Age of the port in the current state: 0d:00h:13m:22s
Port: Gi4/0/10
------------
Port state = Up Sngl-port-Bndl Mstr Not-in-Bndl
Channel group = 46 Mode = Active Gcchange = -
Port-channel = null GC = - Pseudo port-channel = Po46
Port index = 0 Load = 0x00 Protocol = LACP
Flags: S - Device is sending Slow LACPDUs F - Device is sending fast LACPDUs.
A - Device is in active mode. P - Device is in passive mode.
Local information:
LACP port Admin Oper Port Port
Port Flags State Priority Key Key Number State
Gi4/0/10 SA indep 32768 0x2E 0x2E 0x40B 0x7D
Age of the port in the current state: 0d:00h:13m:27s
Port-channels in the group:
---------------------------
Port-channel: Po46 (Primary Aggregator)
------------
Age of the Port-channel = 0d:00h:18m:51s
Logical slot/port = 10/46 Number of ports = 0
HotStandBy port = null
Port state = Port-channel Ag-Not-Inuse
Protocol = LACP
Port security = Disabled
Time since last port bundled: 0d:00h:18m:11s Gi4/0/10
Time since last port Un-bundled: 0d:00h:15m:04s Gi3/0/10