# Question about VRRP log

**URL:** https://community.a10networks.com/t/question-about-vrrp-log/362
**Category:** ADC - Application Delivery
**Tags:** vrrp-a-ha
**Created:** [December 4, 2015, 12:27pm UTC](https://community.a10networks.com/t/question-about-vrrp-log/362 "2015-12-04T12:27:35Z")
**Posts on this page:** 3
**Page:** 1

<div class="post-metadata">

### Author: ![escgate](https://avatars.discourse-cdn.com/v4/letter/e/51bf81/32.png) [@escgate](https://community.a10networks.com/u/escgate)
#### Post date: [December 4, 2015, 12:27pm UTC](https://community.a10networks.com/t/question-about-vrrp-log/362/1 "2015-12-04T12:27:35Z")

</div>

Hi All

I have been configured VRRP-A on the 4.0.x. What does the following log mean? Something wrong for configuring VRRP? Please advice.

Nov 24 2015 18:30:50 Warning [HA]:VRRP-A device 1 partition 0 vrid 13 has different failover policy settings: failover policy used: 1

VRRP conifguration is;

DEVICE#1 vrrp-a common device-id 1 set-id 1 enable disable-default-vrid

vrrp-a fail-over-policy-template tracking interface ethernet 1 weight 2 ! ! vrrp-a vrid 13 floating-ip 11.11.11.4 floating-ip 10.10.10.10 preempt-mode disable blade-parameters priority 101 fail-over-policy-template tracking ! vrrp-a preferred-session-sync-port ethernet 3 !

DEVICE#2 vrrp-a common device-id 2 set-id 1 enable disable-default-vrid exit !

vrrp-a fail-over-policy-template tracking interface ethernet 1 weight 2 exit ! ! vrrp-a vrid 13 floating-ip 11.11.11.4 floating-ip 10.10.10.10 preempt-mode disable blade-parameters priority 100 fail-over-policy-template tracking exit exit ! vrrp-a preferred-session-sync-port ethernet 3

Best regards,

---

<div class="post-metadata">

### Author: ![dshin](https://avatars.discourse-cdn.com/v4/letter/d/f05b48/32.png) [@dshin](https://community.a10networks.com/u/dshin)
#### Post date: [December 4, 2015, 8:05pm UTC](https://community.a10networks.com/t/question-about-vrrp-log/362/2 "2015-12-04T20:05:10Z")

</div>

Hi,

This might be a bug in 4.0 as I see an identical fail-over policy template called “tracking”. Also, Is there a reason why you would use weight within the fail over template? I suggest that you use priority cost over weight. I have set a sample config below for you to follow. Let know the result and good luck!

vrrp-a vrid 0  
&nbsp;&nbsp;device-context 1  
&nbsp;&nbsp;&nbsp;&nbsp;blade-parameters  
&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;priority 200  
&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;tracking-options  
&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;route 110.0.0.0 255.255.255.0 priority-cost 255  
Genard

---

<div class="post-metadata">

### Author: ![escgate](https://avatars.discourse-cdn.com/v4/letter/e/51bf81/32.png) [@escgate](https://community.a10networks.com/u/escgate)
#### Post date: [December 6, 2015, 1:18pm UTC](https://community.a10networks.com/t/question-about-vrrp-log/362/3 "2015-12-06T13:18:06Z")

</div>

Hello Genard,  
Thank you for the advice.

I configured the Policy-Based Failover Template to use both the “preempt-mode disable” and the port tracking.  
There are statements in the manunal as blow;  
VRRP-A provides flexible event tracking and policy-based failover support via a template. This feature allows policy-based failover even when VRRP-A preemption is disabled and the ACOS device typically would remain in an Active state, despite VRID priority changes. It allows for event-based failover once a tracked event occurs.

Do you know the another way to apply both the “preempt-mode disable” and the port tracking feature?  
Thanks,  
Vinnie.
